Delayed Throttle Response in 2013 Kizashi

Anything related to the Kizashi can go here, but please look at the other headings first. Your topic may fit better under something else.
KlutzNinja
Posts: 128
Joined: Wed Dec 04, 2019 6:58 am

LeoFromDE wrote:
KuroNekko wrote:I also changed my spark plugs recently and cleaned my MAF, TB, and PCV valve. My Kizashi with 104,000 miles with the manual transmission runs very well.
Do you know where to find the torques for those things by any chance?
I'm guessing the one for spark plugs is in the manual but I wouldn't know where to look for the others
Spark plug torque is 25 Nm (2.5 kg-m, 18 lb-ft)
LeoFromDE
Posts: 18
Joined: Tue Dec 01, 2020 8:48 pm

KlutzNinja wrote: Spark plug torque is 25 Nm (2.5 kg-m, 18 lb-ft)
Thanks I hope someone knows the other ones because I didn't find them yet :?
LeoFromDE
Posts: 18
Joined: Tue Dec 01, 2020 8:48 pm

Sorry nevermind I found a proper repair manual on here :)
So throttle body is 12nm
PCV is 2,5nm
MAF is 0,9nm

Although I think I'll keep some of those on during cleaning now that I saw the positions
TB16
Posts: 2
Joined: Sat Dec 12, 2020 6:57 pm

Endeavour1200 wrote:
TB16 wrote:Hi, so I've the same exact problem in my 2012 kizashi MT. The is a delay in the throttle response. I'll be going for a service next month and will talk to my service advisor here in New Delhi. Let's see. Could be as simple as a dirty throttle body? What do you think?
Hey @TB16 , so i was wondering if your kizashi has any error codes? Perhaps a bad O2 sensor (that my car has)? This may help us diagnose the delayed response, as it may be related to the O2 sensor. Thanks.
By error codes do you mean CEL on the instrument display? I'll be taking the car for service next week. Will update post that.
Endeavour1200
Posts: 49
Joined: Tue Nov 10, 2020 11:36 am

TB16 wrote:
Endeavour1200 wrote:
TB16 wrote:Hi, so I've the same exact problem in my 2012 kizashi MT. The is a delay in the throttle response. I'll be going for a service next month and will talk to my service advisor here in New Delhi. Let's see. Could be as simple as a dirty throttle body? What do you think?
Hey @TB16 , so i was wondering if your kizashi has any error codes? Perhaps a bad O2 sensor (that my car has)? This may help us diagnose the delayed response, as it may be related to the O2 sensor. Thanks.
By error codes do you mean CEL on the instrument display? I'll be taking the car for service next week. Will update post that.
Yes, a check engine light, a blinking warning triangle and a 'service engine' message on the Mid display. Okay do update after the service. Thanks.
Endeavour1200
Posts: 49
Joined: Tue Nov 10, 2020 11:36 am

TB16 wrote: Wed Dec 30, 2020 2:20 pm By error codes do you mean CEL on the instrument display? I'll be taking the car for service next week. Will update post that.
@TB16 any updates? did you check with your service supervisor?
Post Reply